Issue when upgrading to EPiServer 7.5

Dec 6, 2013 at 9:44 AM
Hi

I'm getting an error when upgrading to episerver 7.5, any idea's.

Unable to load one or more of the requested types. The following information may be a subset of the Type/LoaderException information present - inspect with debugger for complete view.
Check assemblies [OpenWaves.EPiServer.GeoProperties, Version=1.0.87.162, Culture=neutral, PublicKeyToken=null] and/or types [OpenWaves.EPiServer.GeoProperties.PropertyGeoObjectEditorDescriptor,
OpenWaves.EPiServer.GeoProperties.AssemblyResources,
OpenWaves.EPiServer.GeoProperties.EditorDescriptorExtensions,
OpenWaves.EPiServer.GeoProperties.PropertyGeoObjectControl`1,
OpenWaves.EPiServer.GeoProperties.GeoObjectPropertyWebControl,
OpenWaves.EPiServer.GeoProperties.PropertyGeoPoint,
OpenWaves.EPiServer.GeoProperties.GeoPoint,
OpenWaves.EPiServer.GeoProperties.GeoPointExtensions,
OpenWaves.EPiServer.GeoProperties.PropertyGeoPointControl,
OpenWaves.EPiServer.GeoProperties.PropertyGeoPointViewControl,
OpenWaves.EPiServer.GeoProperties.PropertyGeoPointEditorDescriptor,
OpenWaves.EPiServer.GeoProperties.PropertyGeoPointViewEditorDescriptor,
OpenWaves.EPiServer.GeoProperties.GoogleMapsApiInfo,
OpenWaves.EPiServer.GeoProperties.PropertyGeoRectangle,
OpenWaves.EPiServer.GeoProperties.GeoRectangle,
OpenWaves.EPiServer.GeoProperties.PropertyGeoRectangleControl,
OpenWaves.EPiServer.GeoProperties.PropertyGeoRectangleEditorDescriptor,
System.Diagnostics.Contracts.__ContractsRuntime,
System.Diagnostics.Contracts.RuntimeContractsFlags,
System.Diagnostics.Contracts.RuntimeContractsAttribute]. Information from LoaderExceptions property [Could not load type 'EPiServer.UI.ContentBaseSystemPage' from assembly 'EPiServer.UI, Version=7.5.394.2, Culture=neutral, PublicKeyToken=8fe83dea738b45b7'.,
Could not load type 'EPiServer.UI.ContentBaseSystemPage' from assembly 'EPiServer.UI, Version=7.5.394.2, Culture=neutral, PublicKeyToken=8fe83dea738b45b7'.].
Jan 15, 2014 at 2:59 PM
I get the same error.
Did you find a solution for this?
Jan 20, 2014 at 4:30 PM
The only solution is to download the source for the package and replace ContentWebFormsBase with WebFormsBase and recompile.


See Breaking change notes.

http://world.episerver.com/Documentation/Items/Upgrading/EPiServer-CMS/75/Breaking-changes/

SystemPageBase has been obsoleted

The base class SystemPageBase has been obsoleted. Instead, you can use either WebFormsBase or ContentWebFormsBase that are located in the EPiServer.Shell.WebForms namespace in the EPiServer.UI assembly. As a side note, none of the namespaces in the EPiServer.UI assembly, except the newly added classes in the EPiServer.Shell namespace, are intended for public usage. They will, however, remain as long as there are need for them in the built in user interface (mostly the administrative interface).

http://world.episerver.com/Documentation/Items/Upgrading/EPiServer-CMS/75/Breaking-changes/
Nov 7, 2014 at 3:59 AM
Hello Guys,

Is there update planned for the GeoProperties plugin?
It is such an amazing plugin, it would be a shame to not be able to use it in EPIServer 7.5

Cheers,